Mac OS X 10.7 support stopping in patch 7.15

By KoukakuKidoutai

We’re going to be deprecating support for Mac OS X 10.7.5 (Lion) during patch 7.15, and updating our minimum system specs for League from 10.7 to 10.8 (Mountain Lion). If you need the upgrade from 10.7 to 10.8, you can purchase the OS from Apple’s website.

The current version of macOS, 10.12 Sierra (released last year), is also available. You can read about League’s overall minspec requirements for Mac and Windows on Riot’s support page.

It’s been three years since we made a change to OSX minspec requirements, and we want to move ahead with it now for a couple of reasons:

  • Continuing to support OS X 10.7 is becoming increasingly difficult as more third party systems and products are dropping support for Lion
  • We’re unable to update our C++ compiler – the next update to the software will no longer allow targeting for Lion, and we will have to continue to maintain janky development workarounds to ensure stable Mac builds

We'll let you know if there are any updates or changes to this plan.

As a side note, we know that some Mac users have reported stability issues with the updated League client, and we hope that taking dev time from much older versions of macOS will improve our ability to raise performance benchmarks for Mac players overall.


2 months ago